ЦЕНТР
   ТЕСТИРОВАНИЯ
ЦЕНТР ДОВУЗОВСКОЙ ПОДГОТОВКИ 
УлГТУ 
НовостиДокументыАбитуриентуШкольникуНа заметку<Тесты>ПрофориентацияРезультатыКонтакт!Гостевая книгаФорумНП "ЦОКО"

Тест по Информатике

вариант 2

Выберите номер правильного ответа.


Вопрос №1. Число байт, необходимое для записи числа 812

5
10
36
96
192


Вопрос №2. Выражение ((m+1/(m-n)>=3) и ((P или Q) = не (не Р и не Q)) истинно при значениях переменных Р=да, m=3.

n=-6, Q=да
n=-4, Q=нет
n=2, Q=нет
n=4, Q=да
n=6, Q=нет


Вопрос №3. Дана таблица значений а[1..n,1..n]
-1
8
3
-7
2
2
6
0
4

в результате работы алгоритма

нц для i от 1 до div(n,2)
| нц для j от 1 до n
| | c:=a[i,j]; a[i,j]:=a[n-i+1,j]; a[n-i+1,j]:=c;
| кц
кц

значения переменных будут соответственно равны

a[3,2]=3, a[2,2]=-1
a[3,2]=6, a[2,2]=2
a[3,2]=2, a[2,2]=8
a[3,2]=8, a[2,2]=2
a[3,2]=-7, a[2,2]=2


Вопрос №4. Даны утверждения:
1) Бит - это 8 байт.
2) Электронная почта дает возможность пользователям, находящимся на больших расстояниях друг от друга обмениваться сообщениями и файлами.
3) Драйвер - это программа, обеспечивающая взаимодействие операционной системы с переферийным устройством (принтером, дисководом, дисплеем и.т.п.).
Среди них верными являются только

1
2
3
1 и 2
2 и 3


Вопрос №5. Задана строка "110010100011" и три правила преобразования
А. Тройка символов "110" заменяется тройкой символов "100";
В. Тройка символов "100" заменяется тройкой символов "010";
С. Тройка символов "010" заменяется тройкой символов "110";
Применение каждого правила состоит в следующем. Если тройка, состоящая из 1-го, 2-го и 3-го символов, попадает под это правило, то символы заменябтся, иначе, замена не производится. Далее (в любом случае) проверяется тройка, состоящая из 2-го, 3-го и 4-го символов и т.д. до конца строки.
Строка "101010001011" получена из исходной последовательным применением правил

А и В
А иС
В и А
В и С
С и А


Вопрос №6. В результате выполнения фрагмента алгоритма

m:=abs(a) ; n:=abs(b);
нц пока (m>0) и (n>0)
| если (m>n)
| | то m:=mod(m,n)
| | иначе n:=mod(n,m);
| все;
кц
f:=m+n;

Переменная f приняла значение 9. Это справедливо для пары чисел

a=81, b=27
a=-33, b=24
a=15, b=-6
a=36, b=9
a=-24, b=36


Вопрос №7. Тело цикла во фрагменте алгоритма

В:=нет; x:=48;
нц пока не В
| B:=(abs(x)<5); x:=div(x,3)+2
кц

выполнится

5 раз
4 раза
3 раза
2 раза
1 раз


Вопрос №8. Фрагмент алгоритма

нц для k до 3
| если (x[k]>x[2*k])
| | то S:=x[k]; x[k]:=x[2*k]; x[2*k]:=S;
| все
кц

упорядочивает по возрастанию массив

(16, 3,11,77,6,2)
(6,3,2,16,77,11)
(11,2,6,3,16,77)
(11,16, 77,2,6,3)
(77,16,6,2,3,11)


Вопрос №9. На печать в результате выполнения фрагмента алгоритма:

нц пока n<>0
| вывод (2+mod(n,10));
| n:=div(n,10)
кц

было выведено число 117115. Значение переменной n перед выполнением, этого фрагмента алгоритма было равно

3543
3763
5987
3959
5893


Вопрос №10. При построении алгоритма вычисления суммы отрицательных элементов таблицы a[1..N] из набора блоков

A s:=0; нц для k   B s:=0; нц для i
C все кц D от 1 до N
E если (0>a[i]) F если (0<a[k])
G то s:=a[k]+s H то s:=s+a[i]


не используются блоки:

B, E, G
A, F, G
B, F, G
A, E, G
B, E, H


Вопрос №11. Приведенный график описывается оператором

 
если abs(x)>1
| то y:=abs(x-1)+1;
| иначе y:=-1+sqrt(4-sqr(x +1));
все;
если abs(x)>1
| то y:=abs(x-1)-1;
| иначе y:=-1+sqrt(4-sqr(x +1));
все;
если abs(x)>1
| то y:=abs(x-1)+1;
| иначе y:=-1-sqrt(4-sqr(x +1));
все;
если abs(x)>1
| то y:=abs(x-1)+1;
| иначе y:=-1-sqrt(4-sqr(x +1));
все;
если abs(x)>1
| то y:=abs(x-1)-1;
| иначе y:=-1+sqrt(4-sqr(x +1));
все;


Вопрос №12. Результатом выполнения данного алгоритма будет

завершение работы с выходными значениями А=-3; С=3
завершение работы с выходными значениями А=1; С=-1
завершение работы с выходными значениями А=-2; С=-3
завершение работы с выходными значениями А=0; С=-5
зацикливание


Вопрос №13. Прямоугольник со сторонами а и b входит в квадрат, стороны которого параллельны сторонам прямоугольника и равны d, тогда и только тогда, когда

d>=a или d>=b
d2 >=a2+b2
d>=a и d>=b
4*d2 >=a2+b2
2*d2 >=a2 или 2*d2 >=b2


Вопрос №14. Высказывания А, В, С истинны для точек, принадлежащих кругу, треугольнику или прямоугольнику соответственно. Для всех точек выделенной на рисунке области истинно высказывание

С и неили В)
В и неили А)
А и неили В)
и В) и не С
А и неи С)


Вопрос №15. В отношении целое-часть не находятся понятия

год-месяц
квартира-комната
отец-ребенок
страна-губерния
школа-класс


Вопрос №16. Четырехзначных чисел, в записи которых встречается не более одной семерки, всего существует

2673
2916
8505
9234
9477


Вопрос №17. Задан набор геометрических фигур. Вместо знака "?" должна находится фигура


Вопрос №18. 3а круглым столом сидят мужчины А, В, С и женщины D, Е, F. Известно, что А и В сидят рядом, D сидит напротив С. Из утверждений
I. все три женщины сидят подряд
J. Е сидит напротив В
К. две женщины сидят напротив друг друга
при разных расположениях истинными могут оказаться

только одно
I и J
I и K
J и K
все три


Вопрос №19. Рекуррентное соотношение xi=0.5*xi-1+0.5*a/xi-1 при положительном а может быть использовано для быстрого вычисления



а2
а4
1/2а4


Вопрос №20. В текстовом редакторе фрагмент текста

Класс; Предмет; Часы; Учитель
10А;; Химия; 4; Петров
9В; Физика 8; Лаптев
8Б История; 4; Коршунов

преобразован в таблицу, разделитель - символ ";". Третий столбец полученной таблицы имеет вид

Часы
Предмет
Часы
Учитель
 
4
 
Химия
Химия
Химия 4
8
8
Лаптев
8 Лаптев
8
4
История
Коршунов
Коршунов
4

Вопрос №21. Представлен фрагмент электронной таблицы, содержащий числа и формулы.

 
J
K
L
22
5
7
9
23
=J22+K22
 
=J22+K22
24
 
 
 

После вычисления значение в ячейке L24 равно 8. Ячейка L24 содержит формулу

=СРЗНАЧ(J22;K23)
=СРЗНАЧ(J22:K23)
=СРЗНАЧ(L22:K23)
=СРЗНАЧ(L23:K23)
=СРЗНАЧ(J22:L22)


Вопрос №22. Представлен фрагмент электронной таблицы.

 
А
В
1
1
=A2*4+B2
2
2
=A3+B3
3
=A2+A1
 
4
   

Из формул
1. =СУММ(А1:А3)
2. =СУММ(В1:А3)
3. =А4
4. =В1+В2
в ячейку В3 допускается вставить только формулы

1 и 3
1 и 2
1 и 4
1, 3 и 4
1, 2, 3 и 4


Вопрос №23. Представлена база данных "Классы школы"

 
Колич. учеников
Староста
27
Колесник
10а
26
Андреев
30
Чебаев
11а
18
Раков
10б
24
Крупинский

После сортировки в порядке возрастания по полю "Класс" сведения о 10б классе переместятся на

4 строки вверх
1 строки вверх
3 строки вверх
2 строки вверх
0 строк


Вопрос №24. Представлена база данных "Расписание уроков"

День
N_урока
Кабинет
Предмет
Преп
Класс
1
пн
2
32
матем
Голубева
2
пн
2
21
физика
Иванова
10а
3
вт
4
25
литер
Зайцев
4
вт
3
25
литер
Зайцев
5
чт
4
31
физика
Зайцева
10б
6
пт
3
32
матем
Голубев
7
чт
2
41
химия
Панина
8
пн
1
28
матем
Петров
10а
9
вт
1
41
химия
Панина
10б

Запросу, содержащему выражение N_урока>2 или Класс>'8б', удовлетворяют только записи'

1, 2, 3, 4, 5, 6, 7
5, 8, 9
3, 4, 5, 6
1, 3, 4, 5, 6, 7
1, 3, 4, 7


Вопрос №25. Из данных адресов
1. Formoza@
2. rrr@mgpu.msk.ru
3. user@host.bitnet
адресами электронной почты в сети Internet могут быть только

1
2
3
1 и 2
2 и 3


Если в ответе получается число в виде дроби, то округлите его до целого числа.

Вопрос №26.
Числа X=1204, Y=1035, Z=2414 заданы в различный системах счисления.Сумма тех из них, которые кратны 4, в десятичной системе равна


Вопрос №27. Если элементы массива А[1..6] равны соответственно 6, 5, 4, 3, 2, 1, то значение выражения F[F[F[3]]]+div(F[2], F[4]) равно



Вопрос №28. В примере SST-SS=UU разные цифры заменены разными буквами. Значение 3S+5T+2U равно


Вопрос №29. Значение переменной n после выполнения фрагмента алгоритма

n:=0;
нц
для
k от 1 до 1000
| если не mod(k,5)=0 и mod(k,3)=1
| | то n:=n+1
| все
кц
равно


Вопрос №30. Следующий член последовательности 11  21  1112  3112  211213 равен



Если вы обнаружили ошибки в тестах, вариантах ответов или системе подсчета правильных заданий, напишите нам: rpct@ulstu.ru
г.Ульяновск, ул.Северный Венец 32, ауд.100, тел./факс 43-02-03, e-mail:rpct@ulstu.ru