ЦЕНТР
   ТЕСТИРОВАНИЯ
ЦЕНТР ДОВУЗОВСКОЙ ПОДГОТОВКИ 
УлГТУ 
НовостиДокументыАбитуриентуШкольникуНа заметку<Тесты>ПрофориентацияРезультатыКонтакт!Гостевая книгаФорумНП "ЦОКО"

Тест по информатике

вариант 31
2003 год

Выберите номер правильного ответа.


Вопрос №1. Сообщение с объемом информации байт содержит 3072 символа. Мощность использованного алфавита равна


32
4
8
16
2


Вопрос №2. За день первая бригада отремонтировала 4 трактора, вторая – 6 тракторов, третья – 20 и четвертая – 2 (всего в мастерской 4 бригады). Количество информации в битах в сообщении «Трактор отремонтирован 1-й бригадой» равно

5
4
3
1
2


Вопрос №3.

В 8-ричной системе счисления последняя цифра суммы чисел равна

4
3
1
2
6


Вопрос №4. Двузначное число, для которого справедливо равенство , 10-ичной системе счисления равно

32
16
23
17
12


Вопрос №5. Нечетное целое троичное число может оканчиваться на цифры

0, 1, 2
1
0
0, 1
1, 2


Вопрос №6. Фирма Е продала компьютеров больше фирмы С, А меньше Е, F больше D , А больше В, F меньше С. Больше всех компьютеров продала фирма

E
A
B
D
C


Вопрос №7.

Логическая функция Х, удовлетворяющая условию , равна



AB
B


Вопрос №8. Ложность двух высказываний «если курс доллара будет расти, то курс йены будет понижаться» и «неверно, то курс йены или курс рубля будет расти» означает, что будет расти курс (курсы валют могут только расти либо падать)

доллара
йены
рубля
доллара и йены
йены и рубля


Вопрос №9. Структурная формула для упрощенной переключательной схемы, эквивалентной данной, имеет вид

AB




Вопрос №10. Для логической схемы

число различных комбинаций входных сигналов А, В, С, при которых значения А и В совпадают со значением выходного сигнала F , равно

0
1
2
3
4


Вопрос №11. Программа Paint открывает файлы с расширением

a) PAS
b) COM
c) PXC
d) BMP

а и d
c и d
а и c
b и c
b и c и d


Вопрос №12. Из утверждений:

а) Разрядность центрального процессора определяется разрядностью двоичного числа, обрабатываемого за один такт работы процессора
b ) Кэш-память процессора не предназначена для ускоренного чтения данных с диска
с) Кэш-память процессора предназначена для увеличения тактовой частоты
d ) Быстродействие стримера превосходит быстродействие микросхем оперативной памяти являются верными

a
a и b и d
а и b
а и с
b и с


Вопрос №13. Из утверждений:

а) Модем обеспечивает последовательную передачу данных через телефонную сеть
b ) Аналоговые ЭВМ обеспечивают более высокую точность вычислений, чем цифровые
с) Слот – разъем для установки дополнительных устройств
d ) Операционная система может загрузиться при выключенной клавиатуре являются верными

а и d
b и d
а и b и d
a и с
c


Вопрос №14. Правильное соответствие названий программ и их функционального назначения
A
Программа диагностики ЭВМ
1
Сервисная программа
B
Отладчик
2
Прикладная программа
C
Табличный процессор
3
Инструментальная программа

А – 3; В – 1; С – 2
А – 2; В – 1; С – 3
А – 1; В – 3; С - 2
А – 3; В – 2; С – 1
А – 2; В – 3; С – 1


Вопрос №15. Космический полет – это

моделируемый процесс
моделируемый объект
цель моделирования
моделируемая характеристика
закон поведения модели


Вопрос №16. Пропущенный член в последовательности 1, 3, 15, 105, …, 10395 с учетом правила ее формирования равен

845
525
1685
945
1575


Вопрос №17. Симметричная относительно главной диагонали матрица составлена из чисел 4, 4, 4, 4, 2, 2, 2, 3, 3. Максимально возможная сумма элементов над побочной диагональю равна

12
8
10
14
9


Вопрос №18. Минимальный индекс члена последовательности {5 i - 1}, i=1, 2, 3,…, впервые совпавшего с простым числом, равен

5
3
4
6
7


Вопрос №19. Вычисленное по блок-схеме значение переменной F для входных данных 4, 6, 3 равно

-9
5
-6
2
3


Вопрос №20. Вычисляемое в программе
ШКОЛЬНЫЙ АЯ
QBASIC
PASCAL


алг условие ( рез цел S )
нач цел X , Y , Z
X:=4; Y:=2; Z:=4
если Y * Z – X >0
то X := Y – Z ; Y := Z + X
Z := Y + X
иначе X := Y * Z ; Y := Z * X
X := Y * Z
все
S:=X+Y*(Z+1)
вывод S
кон

DEFINT X, Y, Z, S
X=4 : Y=2 : Z=4
IF Y*Z – X>0 THEN
X=Y – Z: Y=Z+X: Z=Y+X
ELSE
X=Y*Z: Y=Z*X
X=Y*Z
END IF
S=X+Y*(Z+1)
PRINT S END

VAR X, Y, Z, S: INTEGER ;
BEGIN
X:=4; Y:=2; Z:=4;
IF Y*Z – X>0 THEN
BEGIN X:=Y-Z; Y:=Z+X
Z:=Y+X
END ELSE
BEGIN X:=Y*Z; Y:=Z*X;
X:=Y*Z
END ; S:=X+Y*(Z+1);
WRITE (S)
END .

значение переменной S равно

5
8
0
3
7


Вопрос №21. Вычисляемое в программе
ШКОЛЬНЫЙ АЯ
QBASIC
PASCAL
алг сумма ( рез цел S )
нач цел I, J
S :=1
нц для I от 1 до 3
нц для J от 1 до 3 – I
S:= S+2*I – J
кц
кц; вывод S
кон

DEFINT I, J, S
S=1
FOR I=1 TO 3
FOR J=1 TO 3 – I
S=S+2*I-J
NEXT J
NEXT I
PRINT S

VAR I, J, S: INTEGER
BEGIN
S:=1;
FOR I:=1 TO 3 DO
FOR J:=1 TO 3-J DO
BEGIN
S:=S+2*I-J
END ;
WRITE (S) END .

Значение переменной S равно

6
9
8
3
5


Вопрос №22.Вычисляемое в программе
ШКОЛЬНЫЙ АЯ
QBASIC
PASCAL

алг сумма ( рез вещ S )
нач цел I , вещ T
T:= 1; S:=T
нц для I от 1 до 99
T:=T/(2*I+1)/(2*I)
S:=S+T
кц
вывод S
кон

DEFINT I
T=1: S=T
FOR I=1 TO 99
T=T/(2*I+1)/(2*I)
S=S+T
NEXT I
PRINT S
VAR I: INTEGER ;
S, T: REAL ;
BEGIN
T:=1, S:=T;
FOR I:=1 TO 99 DO
BEGIN
T:=T/(2*I+1)/(2*I);
S:=S+T
END ;
WRITE (S) END .

значение суммы S соответствует формуле с номером






Вопрос №23. Вычисляемое в программе
ШКОЛЬНЫЙ АЯ
QBASIC
PASCAL
алг вычисление ( рез цел S )
нач цел I, J
I:= 1; S:=2; J:=10
нц пока ( I <= J ) и ( S <5)
S:=S+ мод (J, I)
I:=I + 2; J:=J - 2
кц; вывод S
кон
DEFINT I, J, S
I= 1: S= 2: J= 10
WHILE I<=J AND S < 5
S=S + J MOD I
I=I + 2; J=J – 2
WEND
PRINT S
END
VAR I, J, S: INTEGER ;
BEGIN
J:=10; WHILE (I<=J) AND (S < 5) DO
BEGIN S=S + J MOD I;
I:=I + 2; J:=J – 2
END ; WRITE (S)
END .

значение переменной S равно

5
7
8
6
4


Вопрос №24. Вычисляемое в программе
ШКОЛЬНЫЙ АЯ
QBASIC
PASCAL
алг таблица ( рез цел S )
нач цел I , цел таб A[1 : 6]
A[1]:=1; A[2]:=2; S:=0
нц для I от 3 до 6
A[I]:= мод (A[I-1]*A[I-2],6)+1
кц
нц для I от 1 до 6
A[A[I]]:=A[I]
S:=S+A[I]
кц
вывод S
кон
DIM A(6) AS INTEGER
DEFINT I, S
A(1)=1 : A(2)=2 : S=0
FOR I = 3 TO 6
A(I)=(A(I-1)*A(I-2)) MOD 6 +1
NEXT I
FOR I=1 TO 6
A(A(I))=A(I)
S=S+A(I)
NEXT I
PRINT S
END
VAR I, S: INTEGER ;
A: ARRAY [1..6] OF I NTEGER ;
BEGIN A[1]:=1; A[2]:=2;
S:=0;
FOR I:=3 TO 6 DO
A[I]:=(A[I-1]*A[I-2])
MOD 6+1;
FOR I:=1 TO 6 DO
BEGIN A[A[I]]:=A[I];
S:=S+A[I]
END; WRITE (S); END .

значение переменной S равно

16
14
20
18
26


Вопрос №25. Присвоение – это

базовая алгоритмическая структура
отношение
данные
выражение
оператор


Вопрос №26. Из таблицы 3 3 (все линии нарисованы сплошным) получить указанную фигуру. Минимальное количество обращений к инструменту ВНЕШНИЕ ГРАНИЦЫ равно


5
3
2
6
4


Вопрос №27. Опция СТИЛЬ текстового редактора Word входит в меню

Таблица
Правка
Сервис
Вставка
Формат


Вопрос №28. Значение в ячейке С3 электронной таблицы
 
A
B
C
1
3
9
6
2
=СУММ (А1:С1)
=В1 – А1
=МИН(А1:В3)
3
0
4
=С1 + С2

после деления всех элементов первой строки на 3 уменьшится на

2
3
5
7
4


Вопрос №29. Значение в ячейке D 4 электронной таблицы
 
A
B
C
D
1
 
2
4
=МИН(А1:С2)
2
 
4
=МИН(А1:В2)
 
3
1
5
=СРЗНАЧ(А1:С2)
=СРЗНАЧ(А3:С3)
4
3
   
=СУММ( D 1: D 3)

равно

4
8
6
5
7


Вопрос №30. В базе данных с атрибутами Самолет, Цена билета, Аэропорт добавлена запись со значениями Самолет = «Боинг-747», Цена билета = 310$, Аэропорт = «Домодедово». Эта запись удовлетворяет условиям запросов

a) (Самолет «Боинг-747» и Цена билета = 310$) или Аэропорт «Домодедово»

b) (Самолет = «Боинг-747» или Цена билета 310$) и Аэропорт = «Домодедово».

c) (Самолет = «Боинг-747» или Цена билета = 310$) или Аэропорт = «Домодедово».

d) (Самолет = «Боинг-747» и Цена билета = 310$) или Аэропорт «Домодедово»

а и с
b и c и d
b и c
a и d
b и d


Вопрос №31. В базе данных
ФИО РОСТ ВЕС
1
ИВАНОВ 165 67
2
АЛЕШИН 170 75
3
СИДОРОВ 168 73
4
ЯШИН 184 74
5
СИЗОВ 171 68
6
МИНИН 167 66

запросу «неверно, что рост = 170 и вес >= 73» удовлетворяют только записи

4, 5, 6
1, 3, 4, 5, 6
1, 4, 5, 6
1, 4, 6
2, 6


Вопрос №32. Минимальное количество прямоугольников для изображения с помощью графического редактора Paint фигуры

равно

4
6
5
7
3


Вопрос №33. Количество правильных имен сайта

a) www.dum.сom
b) www.tt.net
c) www.sаrt.tеst.one
d) www.rest.org
e) www.ml.ru

равно

4
5
3
2
1


Вопрос №34. Из режимов просмотра

a) режим сцепления
b) режим структуры
c) режим инверсии
d) режим образцов

в PowerPoint используются

a , b , c
a и b
b и d
c
а и d


Вопрос №35. В растровом графическом редакторе из утверждений

a) Нельзя изменять цвета отдельных пикселей изображения
b) Качество изображения очень чувствительно к масштабированию
c) Нельзя загружать рисунки из файлов
d) Можно стирать произвольные части изображений
верными являются

a и c и d
b
b и d
a и b и c
a и b и d


В следующих заданиях ответом должно быть целое число, равное значению искомой величины.

Вопрос №36. 11101100 – прямой код числа Х, 11010101 – дополнительный код числа Y в однобайтовом формате со старшим знаковым разрядом. Восьмеричное представление наибольшего из этих чисел имеет вид


Вопрос №37. Количество строк в таблице истинности для логической функции , в которых значение функции совпадает со значением А, равно


Вопрос №38. Вычисляемое в программе
     
алг МАТРИЦА ( рез цел S )
нач цел I, J
цел таб А[1:3, 1:3]
нц для I от 1 до 3
нц для J от 1 до 3
А [I, J]:= мод (I, J)
кц
кц ; S:=0
нц для I от 2 до 3
нц для J от 1 до 4 – I
если А[ J , I + J -1]=1
то S:=S+1
все
кц
кц; вывод S ; кон
DEFINT I, J, K, S
DIM A(3, 3) AS INTEGER
FOR I=1 TO 3
FOR J=1 TO 3
A(I, J)= I MOD J
NEXT J, I
S=0
FOR I=2 TO 3
FOR J=1 TO 4-I
IF A(J, I+J-1)=1 THEN
S=S+1
END IF
NEXT J, I
PRINT S
VAR I, J, S: INTEGER
A: ARRAY [1..3, 1..3] OF
INTEGER;
BEGIN
FOR I:=1 TO 3 DO
FOR J:=1 TO 3 DO
A[I, J]:=I MOD J;
S:=0;
FOR I:=2 TO 3 DO
FOR J:=1 TO 4 - I DO
IF A[J, I+J-1]=1 THEN
S:=S+1;
WRITE (S)
END.

значение переменной S равно


Вопрос №39. Вычисляемое в программе
     
алг слово ( рез цел F )
нач цел L , лит А
А:= « babaa »; F :=4
L:= длин (А)
нц пока F >=3
если мод ( L :2)=0
то А:= A [ L - F +4: L ]
иначе
А:= A [1: F ]
все
L := длин (А)
F := L
кц
вывод L
кон
DEFINT I, F, L
A$= “babaa”
F=3: L=LEN(A$)
WHILE F>=3
IF L MOD 2=0 THEN
A$ = RIGTH $ (A$, F-3)
ELSE
A$ = LEFT $ (A$, F)
END IF
L= LEN (A$)
F = L
WEND
PRINT L
VAR I, F, L: INTEGER ;
A: STRING ;
BEGIN A:= ‘babaa';
F:=4; L:= LENGTH (A);
WHILE F>=3 DO
BEGIN
IF L MOD 2 = 0 THEN
A:= COPY (A, L-F+4, F-3)
ELSE
A:= COPY (A, 1, F);
L:= LENGTH (A); F:=L
END ;
WRITE (L)
END .

значение переменной L равно


Вопрос №40. Значение в ячейке С4 электронной таблицы
 
A
B
C
1
7
=MAX(A1:A2)
=МИН(А1:В1)
2
=$ A $1+6
1
=МИН(А2:В2)
3
   
=СРЗНАЧ(С1:С2)
4
     

после операций над второй строкой ВЫДЕЛИТЬ, КОПИРОВАТЬ, ВСТАВИТЬ СКОПИРОВАННЫЕ ЯЧЕЙКИ СО СДВИГОМ ВНИЗ равно



Если вы обнаружили ошибки в тестах, вариантах ответов или системе подсчета правильных заданий, напишите нам: rpct@ulstu.ru
г.Ульяновск, ул.Северный Венец 32, ауд.100, тел./факс 43-02-03, e-mail:rpct@ulstu.ru